Jump to content
Sign in to follow this  
Nafn

Passenger's window?

Recommended Posts

Hey guys,

 

My passenger window doesn't function when the button is pressed.

 

I'm assuming ive blown a fuse?

Would any one know which one I'd need to replace?

 

Thanks?

Share this post


Link to post
Share on other sites

There window makes no sound. Doesn't sound like its trying to move.

It just doesn't function with the switch on the passenger door aswell as the drivers door. Drivers side window is fine. Just no sign of life for the passenger.

Dont know what else i can say.

Im putting my money on the fact its a fuse though. I just needto know which one to replace to see if its actually the fuse or not.

Share this post


Link to post
Share on other sites

There window makes no sound. Doesn't sound like its trying to move.

It just doesn't function with the switch on the passenger door aswell as the drivers door. Drivers side window is fine. Just no sign of life for the passenger.

Dont know what else i can say.

Im putting my money on the fact its a fuse though. I just needto know which one to replace to see if its actually the fuse or not.

 

I doubt its a fuse. I would say its an open circuit (cut wire or not plugged in properly)

Share this post


Link to post
Share on other sites

Where would the plug be? I took the trim off and everything looked fine, should have got my multimeter out.

Share this post


Link to post
Share on other sites

my money would be on the switch has buggered up.

had a few come into my work for power window problems and yeah it was the switch

Share this post


Link to post
Share on other sites

The thing is though, neither of the switches allow the window to function.

 

Passenger and drivers door switches for the passenger window, dont receive any life from the window itself. I dont think both switches would go at once.

 

Thanks for the input

Share this post


Link to post
Share on other sites

My passenger window goes up n down real slow n jolty and then just stops and won't move! has anyone had this as every post I'm reading is when they are completely stopped and now movement Any one know? :)

Share this post


Link to post
Share on other sites

Yo , you haven't accedently pushed in the passenger window lock botton ?

Share this post


Link to post
Share on other sites

Uhm, im pretty sure my s14 doesnt have any window locks but thanks.

Im thinking the motor may have died.

 

Yo , you haven't accedently pushed in the passenger window lock botton ?

 

Yeah.. thanks alot for this, I checked and discovered what the anonymous button does. Thanks alot for commenting :thumbsup:

Silly me just waved you off abit.

 

All good now 8) silly mistake.

 

Thanks everyone.

Edited by Nafn

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×