Jump to content
Sign in to follow this  
Harthorn

problem with clutch i think

Recommended Posts

hey guys i got a wrp10

 

when my car idles, i can hear a rattle (squeek rattle don't know how to describe) sometimes.. i think its my clutch

 

when i drive it, first gear and slowly let out clutch, i can hear the rattle aswell

 

but after that i don't hear anything and it feels ok i think, but car doesn't feel as it should during lift off.. slightly slip maybeee...

 

anyone have similar problems?? and think its definately clutch..

 

anyone have any suggestions on clutches/flywheels for a 200kw-250kw rex application

 

thanx!!

Share this post


Link to post
Share on other sites

Does it happen just after you've parked somewhere and had the handrake on, and when u slowly take off u can hear it? If it is i have the same problem, and its the handbrake not fully releasing when you take it off, which after u get out the car park it puts itself back into place anyways....

Share this post


Link to post
Share on other sites

yea.. usually when i stop or just lift off

 

how come it doesn't fully release :/.. is it a common problem with rexes??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×